Maplerad - CARD SERVICE DOWNTIME – Incident details

CARD SERVICE DOWNTIME

Monitoring
Major outage
Started 1 day ago

Affected

API

Major outage from 10:45 AM to 11:47 AM, Operational from 11:47 AM to 12:00 AM

Issuing

Major outage from 10:45 AM to 11:47 AM, Operational from 11:47 AM to 12:00 AM

Customer Card API

Major outage from 10:45 AM to 11:47 AM, Operational from 11:47 AM to 12:00 AM

Business Card API

Major outage from 10:45 AM to 11:47 AM, Operational from 11:47 AM to 12:00 AM

Updates
  • Update
    Update

    Hello Team,

    We’re currently seeing elevated decline rates and potential fraud activity on certain BINs, particularly in high-risk regions. In coordination with our banking partner, these BINs are being phased out.

    What’s Next:

    • A list of impacted cards will be shared.

    • Replacement activity is scheduled to take place from today through Tuesday, September 23, 2025.

    • All replacements will be processed at no cost.

    Thank you for your understanding as we work through this.

    Regards,

    Maplerad Team

  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Identified
    Identified

    Hello Team,

    We are currently working on the Card Services.

    BIN services are currently undergoing maintenance.

    Thank you for your patience as we work on this.

    Regards,

    Maplerad Team.