Maplerad - Card Service Temporary Downtime – Incident details

Website experiencing major outage

Card Service Temporary Downtime

Resolved
Major outage
Started 2 months agoLasted about 1 hour
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Hello Team,

    This is to bring to your attention,

    Card funding and creation are on hold.

    TAT - within 24 hours.

    We sincerely apologize for the inconvenience.

    Thank you for being so patient.