Maplerad - Customer BVN validation – Incident details

Website experiencing major outage

Customer BVN validation

Resolved
Under maintenance
Started 2 months agoLasted about 2 hours

Affected

API

Under maintenance from 3:06 PM to 5:29 PM

Customer

Under maintenance from 3:06 PM to 5:29 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We have identified an issue with BVN verification during Customer enrollment.

    We are currently working on a fix and the service will be back up within 24hrs.

    Kindly exercise patience with us while we work on it.

    Thank you.