Maplerad - Important Update: Create Your USD Virtual Account & Wallet Funding – Incident details

Website experiencing major outage

Important Update: Create Your USD Virtual Account & Wallet Funding

Resolved
Operational
Started 13 days agoLasted 2 minutes

Affected

Dashboard

Operational from 6:57 AM to 6:59 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Hello Team,

    We hope this email finds you well. To ensure a seamless funding process for your wallet, we kindly ask you to create a USD virtual account for your business. This will allow you to deposit funds to your wallet faster and securely.

    Please note that only deposits of $25,000 or more should be sent to our Maplerad account or wallet address to fund your wallet. Lower amounts can be sent to your USD virtual account once created.

    To create your USD virtual account and proceed with funding, please follow these steps:

    1. Request for USD virtual account services to be profiled on your Maplerad account.

    2. Log in to your account

    3. ⁠Navigate to the “Funding” or “Wallet” section.

    4. ⁠Select “Create USD Virtual Account” and follow the instructions.

    5. ⁠Once your virtual account is set up, use the provided details to transfer funds.

    If you have any questions or need assistance, contact our support team.

    Best regards.